FAQFAQ SearchSearch MemberlistMemberlist  RegisterRegister  ProfileProfile Log in to check your private messagesP.M. Log inLog in
speed control issue

 
Post new topic   Reply to topic    OFNA Nitro Talk Back Forum Forum Index -> Ultra LX Series
View previous topic :: View next topic  

Author Message
adanV



Joined: 07 Nov 2014
Posts: 1

PostPosted: Fri Nov 07, 2014 5:06 pm    Post subject: speed control issue Reply with quote

maybe some one can help me, im sorta new to this.. is there a reason my car stops running after about a minute of use.. i notice that the first of the two green lights on the speed control starts to blink red as soon as it stops running, the wheels still turn it just wont run. I also noticed that the light will only turn red after my remote has powerd on. Is there something causing this or is there a way to fix it? thnx any help is highly appreciated
Back to top
View user's profile Send private message
Author Message
David S.



Joined: 04 Apr 2008
Posts: 443

PostPosted: Mon Nov 10, 2014 9:51 am    Post subject: Reply with quote

First thing to check and see if your batteries are discharged when this happens.
If your batteries are low when this occurs then the low voltage cut-off (LVC) engaged. And you ran out of safe battery voltage
If you ran the model very hard and on terrain such as grass it is possible it shut down because it was starting to overheat. This also can occur.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OFNA Nitro Talk Back Forum Forum Index -> Ultra LX Series All times are GMT - 9 Hours
Page 1 of 1
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
ofna nitro talk back